[ome-users] Upload problem

Woodbridge, Mark R m.woodbridge at imperial.ac.uk
Mon May 12 15:57:31 BST 2014


I have set up a new OMERO server with a blank filesystem/database and successfully imported an image. Then I shut down our old non-functioning server, pointed the new server at the old filesystem/database and have reproduced the import error. So it does appear that some inconsistency between the database and the filesystem is preventing new imports. I guess this could have been due to an unclean shutdown, an out-of-memory error (of which we have had a few recently) or perhaps an NFS issue.

Is there any way to verify/reconcile the filesystem and database so that we can repair the server?

Thanks for all your help so far,


From: Josh Moore [josh at glencoesoftware.com]
Sent: 09 May 2014 15:16
To: Woodbridge, Mark R
Cc: Aleksandra Tarkowska; ome-users at lists.openmicroscopy.org.uk
Subject: Re: [ome-users] Upload problem

Hi Mark,

On May 9, 2014, at 4:07 PM, Mark Woodbridge wrote:

> I did try creating a file inside that folder as the OMERO user and it was successful, so not sure what the issue is. Will keep looking though.

Could you try the same import from the CLI and see if more of the stracktrace is printed?

What I think is happening is that somehow there's a de-synchronization between your /OMERO/ManagedRepository directory and the values in the DB. If import notices that either a directory exists that isn't listed in the DB OR an entry is in the DB but doesn't exist on disk, it will complain.


> On 09/05/14 14:54, Aleksandra Tarkowska wrote:
>> Hi Mark,
>> From what I can see in the codebase
>> 2014-05-09 14:06:43,253 INFO  [        ome.services.util.ServiceHandler]
>> (l.Server-8)  Excp:    ome.services.blitz.repo.RepositoryDaoImpl$Rethrow:
>> rethrow!
>> is thrown when is trying to create a nested path in the repository.
>> Creates each directory in the path if it doen't already exist.
>> Does it give you any clue?
>> Kind regards
>> Ola
>> On 09/05/2014 14:12, "Mark Woodbridge" <m.woodbridge at imperial.ac.uk> wrote:
>>> Hi,
>>> For some reason we can't upload images to our OMERO at the moment and I
>>> can't figure out why! The only log with any recent entries is
>>> Blitz-0.log, so I've attached the complete Insight session where I tried
>>> to upload a jpeg. The disk isn't full and I have tried restarting the
>>> server.
>>> Clicking 'View Exception' and 'Submit' in the client doesn't seem to do
>>> much, so I don't have anything else to go on.
>>> Any ideas would be really appreciated,
>>> Mark.
>>> _______________________________________________
>>> ome-users mailing list
>>> ome-users at lists.openmicroscopy.org.uk
>>> http://lists.openmicroscopy.org.uk/mailman/listinfo/ome-users
>> The University of Dundee is a registered Scottish Charity, No: SC015096
> _______________________________________________
> ome-users mailing list
> ome-users at lists.openmicroscopy.org.uk
> http://lists.openmicroscopy.org.uk/mailman/listinfo/ome-users

More information about the ome-users mailing list