[ome-users] 4.1.0 - cannot connect

W. Chan wpchan at u.washington.edu
Sun Nov 15 10:25:54 GMT 2009

I just installed 4.1.0 on ubuntu 9.0.4 (2.6.28-16-server) but cannot
connect.  For OMERO.web, I ran as a normal user on the ubuntu server, did
"links http://localhost:8000/webadmin", and I got this error.

     * Error: Connection not available, please check your user name and

If I use winxp OMERO.insight, I got the login failure error.  Tried 0 for
tcp_window_scaling but still no imporvement.

No firewall is active on the ubuntu server and the iptable is empty.

Here is the diagnostic.

OMERO Diagnostics Beta-4.1.0-r5585-b12

Commands:   java -version                  1.6.0     (/usr/bin/java)
Commands:   python -V                      2.6       (/usr/bin/python)
Commands:   icegridnode --version          3.3
Commands:   icegridadmin --version         3.3
Commands:   psql --version                 8.3.8     (/usr/bin/psql)

Server:     icegridnode                    running
Server:     Blitz-0                        active (pid = 19987, enabled)
Server:     DropBox                        inactive (disabled)
Server:     FSServer                       inactive (disabled)
Server:     Indexer-0                      active (pid = 20001, enabled)
Server:     OMERO.Glacier2                 active (pid = 20003, enabled)
Server:     OMERO.IceStorm                 active (pid = 20006, enabled)
Server:     Processor-0                    active (pid = 20313, enabled)
Server:     Tables-0                       inactive (disabled)
Server:     TestDropBox                    inactive (enabled)
Server:     Web                            active (pid = 20929, enabled)

Log dir:    /home/omero/omero_dist/var/log exists

Log files:  Blitz-0.log                    40.0 KB       errors=0
Log files:  DropBox.log                    1.0 KB        errors=2
Log files:  FSServer.log                   0.0 KB        errors=1
Log files:  Indexer-0.log                  56.0 KB       errors=3
Log files:  OMEROweb.log                   2.0 KB        errors=2
Log files:  OMEROweb.log.2009-11-15        3.0 KB        errors=3
Log files:  Processor-0.log                8.0 KB        errors=2
Log files:  Tables-0.log                   n/a
Log files:  TestDropBox.log                n/a
Log files:  master.err                     2.0 KB        errors=0
Log files:  master.out                     0.0 KB
Log files:  Total size                     0.12 MB

/OMERO is owned by omero:omero.  When I export the PYTHONPATH, I did
notice that $PYTHONPATH only points to /home/omero/omero_dist/lib/python.
The system has python at /usr/bin/python.  So I don't think that could be
a problem.

Here is a portion of the Blitz log that seem to show something but I do
know enough to make sense out of it.

2009-11-15 01:42:03,900 INFO  [        ome.services.util.ServiceHandler]
(l.Server-8)  Executor.doWork --
2009-11-15 01:42:03,901 INFO  [        ome.services.util.ServiceHandler]
(l.Server-8)  Args:    [null,
ome.tools.spring.InternalServiceFactory at 17a82f1]
2009-11-15 01:42:03,938 INFO  [         ome.security.basic.EventHandler]
(l.Server-8)  Auth:
2009-11-15 01:42:03,959 INFO  [                 org.perf4j.TimingLogger]
(l.Server-8) start[1258278123901] time[58] tag[omero.call.success]
2009-11-15 01:42:03,960 INFO  [        ome.services.util.ServiceHandler]
(l.Server-8)  Rslt:    false

Thanks for your help.

Pang (Wai Pang Chan, wpchan at u.washington.edu, PAB A087, 206-685-1519)
The Biology Imaging Facility (http://depts.washington.edu/if/)

More information about the ome-users mailing list